【宅技术】解决宝塔安装SG11报错

发布于 2019-04-06  2.18k 次阅读


0x001 前言

今天安装微擎插件,就是最近特别火的AI面部看相,然后安装完后,报错内容如下:

SourceGuardian Incompatible loader version. This protected script was encoded with newer version of SourceGuardian. Please download and install the <A HREF="http://www.sourceguardian.com/loaders/">latest loaders</A>. Error code [19] in

然后根据老一辈人的思维,把问题读懂就解决一般了,于是,我用谷歌翻译了一下;

SourceGuardian 不兼容的加载程序版本。此受保护的脚本是用更新版本的sourceguardian编码的。请下载并安装最新的加载程序。中的错误代码[19]

然后大致意思就是 SourceGuardian 这个插件过时了,要更新,百度了一下
SourceGuardian 这个就是宝塔面板里的SG11插件;

微信截图 20190406235515 【宅技术】解决宝塔安装SG11报错
SG11扩展

宝塔面板自带的版本已经跟不上现在加密的步伐了,于是需要手动更新一下
SourceGuardian

0x002 更新 /安装 SourceGuardian

<?php
    echo phpinfo();
?>
  • 然后把详细网址写到这个框框里,如下图所示;回车然后就会自动判断你的服务器该安装那个版本;
微信截图 20190407000024 【宅技术】解决宝塔安装SG11报错
SG11 更新安装界面
  • 在线的检查脚本会根据 phpinfo 的信息,提取到 php 版本信息和扩展路径,然后提示你需要的操作。例如它提示我 extension_dir 应设置为绝对路径而非相对路径:
381da 1302061 20180801141301338 378265304 【宅技术】解决宝塔安装SG11报错

那就改呗,在 php.ini 中找到 extension_dir,将原来的相对路径 ./ext 改为绝对路径。重启 Apache 然后重新执行检测:

82f9a 1302061 20180801141824302 586207343 【宅技术】解决宝塔安装SG11报错

到这一步它提示我需要:

  1. 下载 ixed.5.6.win
  2. 安装到 php 扩展的 ext 目录
  3. 在 php.ini 中加载它:extension=ixed.5.6.win
  4. 重启 Apache

全部修改完成后,在 phpinfo 看到了 SourceGuardian 的相关信息,说明扩展已经生效了:

0x003 结语

宝塔面板还是很好使用的,就是有些插件更新不及时,手动更新下载即可解决问题;

像我这样英语不太好的,可以借助谷歌翻译,毕竟老一辈人讲了,将问题读懂已经解决一半了;


郑州90后一名计算机爱好者,希望能通过网络结交更多朋友!